
Hanthana Linux FAQ
www.hanthana.org

General Information 
   1). What is Hanthana Linux?
   2). What is Fedora?
   3). What is GNU/Linux?
   4). What is a live CD/DVD?
   5). Is Hanthana a stable operating system? Or is it in experimental level?
   6). Can Hanthana be used in a professional or office environment?
   7). Other working with me use Windows operating system. Will it be a disadvantage that 
only me use Hanthana? Will others not be able to open and read the documents I create?
   8). Difference between Hanthana and Fedora
   9). Will Hanthana expire?
   10). Does the installation require a serial number?
   11). Can the packages be updated?
   12). What is the selling price of  a Hanthana disk?
   13). Can I sell Hanthana in my shop? How much do I have to pay for that?
   14). Why does Hanthana project need donation?
   15). Can Hanthana disks be copied and distributed among friends?
   16). What is the latest Hanthana version released?
   17). How long does it take to release a new version of  Hanthana?
   18). What is the next release?
   19). What are the software bundled with Hanthana?
   20). Is it difficult to use Hanthana once Ubuntu is used?
   21). Should Sinhala be installed on Hanthana?
   22). Can mp3, mp4, avi be played on Hanthana?
   23). Can skype be install for Hanthana?
   24). Can Office2007 documents be opened with LibreOffice which is shipped with 
Hanthana?
   25). Can Hanthana installed on the same computer with MS Windows? Will that slow the 
computer?
   26). Is a virus guard required?
   27). Do I need to install Mobile Partner to connect to the internet through my dongle? Is 
there any other solution?
   28). How can I solve issues of  Hanthana Linux?
   29). It bothers me to get a large number of  emails. Is there a way to receive only the latest 
news related to Hanthana?
   30). Can I contribute to Hanthana project?

Hanthana Linux Documentation Team 2009 – 2012 info@hanthana.org

mailto:info@hanthana.org
http://www.hanthana.org/


Hanthana Linux FAQ
www.hanthana.org

Installation 
   1). What are the minimum hardware requirements to install Hanthana?
   2). How to get Hanthana
   3). Can Hanthana be operated on 64 bit computers?
   4). How to install Hanthana?
   5). How to install Hanthana as dual boot?
   6). How can I view my NTFS (Windows NT/2000/XP/2003) partitions?

Desktop Settings 
   1). How to enable Desktop Effects / desktop decorations?
   2). How to turn off  the computer? I cannot locate Shutdown.

Office Applications 
   1). How can I move a document created from LibreOffice in Hanthana to a computer with 
MS Office?
   2). Can a document be converted to a PDF?
   3). Is it only LiberOffice? OpenOffice.org, isn’t it there?
   4). How to type in Sinhala?
   5). Do I need to install fonts to type in Sinhala ?

   6). Can issues such as bold Sinhala characters and displaying of  characters such as "ශ" like 

"ශර" be fixed?

Software Management 
   1). How to install applications on Hanthana ?
   2). How to update software in Hanthana?
   3). How to remove software in Hanthana?
   4). Can exe files be installed in Hanthana? How can I do that?

Software Development 
   1). How to use python 2.7 or 3.2 ?
   2). When a python script is run in geany, the output is not displayed

Network Connection 
   1). How to set the IP Address and other related details ?
   2). How can I connect to the internet using my dongle?
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   3). I installed Hanthana Linux, but I cannot connect to the internet
   4). How can I know the DNS of  my Internet Service Provider (ISP)?

User Management 
   1). How can I change my password?
   2). How to create a new user account in Hanthana?
   3). How to delete a user account in Hanthana?
   4). How can I modify a user account in Hanthana?

Security Settings 
   1). What is SELinux?
   2). What effect will be there for my day to day activities due to SELinux?
   3). How to enable/disable SELinux?

Mobile Phone Settings 
   1). Can SMS and contacts in my mobile phone/dongle be viewed in Hanthana?

Other 
   1). How can I view the space on my hard disk?
   2). How can I view internet speed, CPU and Memory?
   3). How can I find a file in the disk?
   4). How can I find more information on a command in a Linux based system?
   5). How can I log in to the Sinhala user interface of  Hanthana?
   6). What is ‘terminal’?
   7). What is ‘root’?

General Information

1). What is Hanthana Linux?
Hanthana is a remix of  Fedora operating system and it is built so as to better cater the needs 
of  Sri Lankan community. This is distributed free of  charge and it is totally allowed to 
redistribute copies as many as required. In other words, Hanthana Linux is a free and open 
source operating system. Since it is build as a live disk, the operating system can be used and 
tested without installing it. 
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2). What is Fedora?
Fedora is a Linux based operating system developed by the community with the support of  
Red Hat. This can be downloaded free of  charge and usually, latest technologies in the world 
of  open source are bundled with Fedora before any other Linux based systems do. A new 
version of  Fedora is released in every six month. 

TOP

3). What is GNU/Linux?
GNU (GNU - GNU is Not Unix) is a project with the aim of  developing an operating system 
completely with open source software similar to Unix. This project consists of  several 
software such as applications, libraries, development tools etc. Linux is a software for resource 
management and to communicate with hardware. Both these sections, that is GNU and 
Linux, have formed GNU/Linux. Although we simply say Linux today, these names if  
properly named should be GNU/Linux. 

TOP

4). What is a live CD/DVD?
A live disk is a disk which is cable of  running an operating system without installing it. For 
example, an operating system in a live CD/DVD can be used without having any influence on 
your installed operating system. 

TOP

5). Is Hanthana a stable operating system? Or is it in experimental level?
Hanthana is a stable operating system. Since it is based on Fedora, all the advantages, security 
and qualities in Fedora are bundled with Hanthana. 

TOP

6). Can Hanthana be used in a professional or office environment?
Absolutely yes. 

TOP

7). Other working with me use Windows operating system. Will it be a disadvantage 
that only me use Hanthana? Will others not be able to open and read the documents I 
create?
There will not be any problem for you. The documents, graphics or any other documents that 
you create with in Hanthana Linux can be opened and modified in other operating systems as 
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well. Further, they can be shared in a network and printed. This will not have an negative 
impact on your office work. It will be advantageous that you save a lot of  money that would 
cost you to buy software. 

For more information, please visit Hanthana Linux features page on Hanthana Linux web 
site. 

TOP

8). Difference between Hanthana and Fedora
Hanthana Linux contains a collection of  packages for multimedia that are not shipped with 
Fedora. A new version of  Fedora is released in every six months. If  you download a Fedora 
release after few months later it’s release date, the iso will contain only the packages at the 
original release. But with Hanthana, since the iso is rebuilt from time to time you get the 
updated packages with the CD/DVD iso. 

TOP

9). Will Hanthana expire?
No. But if  you want you can install the latest version. 

TOP

10). Does the installation require a serial number?
No. 

TOP

11). Can the packages be updated?
Yes. Once you install a version of  Hanthana, you will get updates for the installed packages 
for a period of  one year. They can be installed as you wish. If  your computer is connected to 
the internet, you can update your software by through Activities > Applications System Tools 
> Software Update or with the “su -c ‘yum update’” or “su -c ‘pkcon update’” commands in 
the terminal (and you will be requested with the root password). 

TOP

12). What is the selling price of  a Hanthana disk?
Free of  charge! You can get a copy through the Hanthana web site or you may make a copy 
from a friend’s copy. 

TOP

Hanthana Linux Documentation Team 2009 – 2012 info@hanthana.org

mailto:info@hanthana.org
http://www.hanthana.org/


Hanthana Linux FAQ
www.hanthana.org

13). Can I sell Hanthana in my shop? How much do I have to pay for that?
Yes, you can sell Hanthana live disks. You do not need to pay any for us. If  you like you can 
donate to the project. You are allowed to sell at a reasonable price that the customers can 
bear. 

TOP

14). Why does Hanthana project need donation?
We conduct this project with no financial benefits, but solely as a social responsibility. But we 
need money to pay for out domain name, to maintain our servers, to print posters and to 
prepare media (CD/DVD) to be distributed free of  charge for school students. 

TOP

15). Can Hanthana disks be copied and distributed among friends?
Since Hanthana is totally free and free of  charge you have the complete freedom to copy and 
distribute among friends. We highly encourage you to do so. 

TOP

16). What is the latest Hanthana version released?
Hanthana 17 

TOP

17). How long does it take to release a new version of  Hanthana?
Once a new Fedora version is released, after some time, the corresponding Hanthana version 
will be released and it contains all the software updates up to the date of  release. 

TOP

18). What is the next release?
Hanthana 18 

TOP

19). What are the software bundled with Hanthana?
A collection of  software for your day to day work, office work and for special requirements 
such as graphic designing and software development are freely shipped with Hanthana. A 
complete list of  software included in Hanthana can be found at 
http://hanthana.org/features.php 

TOP
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20). Is it difficult to use Hanthana once Ubuntu is used?
Hanthana is an operating system based on Fedora. Ubuntu and Fedora are two different 
operating systems supported by two companies. For example lets compare the Fiest car by 
Ford and Micra car by Nissan. Although the speed, facilities and space is almost the same for 
both cars, the internal and outer appearance are slightly different. Similarly, although there 
may be slight differences in Ubuntu and Fedora there will not be an issue in switching 
between each in the similar way that a person get used to drive a different model of  a car 
when required quickly when he/she has already driven another model of  a car. Further, 
Fedora enables the user experience the latest features. We guarantee that it would be easy for 
an Ubuntu user to use Hanthana which is build in a more user friendly manner than Fedora. 

TOP

21). Should Sinhala be installed on Hanthana?
No. Since Hanthana supports Sinhala and Tamil unicode be default, there is no need to install 
Sinhala separately. 

TOP

22). Can mp3, mp4, avi be played on Hanthana?
Yes, Hanthana by default supports many multimedia file types. They can be played 
immediately you install Hanthana. 

TOP

23). Can skype be install for Hanthana?
Skype is available with Hanthana by default. You don’t need to install separately. 

TOP

24). Can Office2007 documents be opened with LibreOffice which is shipped with 
Hanthana?
Yes, at the moment files created with Office 2012 and previous versions can be opened and 
files can be saved so that they can be reopened in OfficeXP, Office2003 and Office2007. 

TOP

25). Can Hanthana installed on the same computer with MS Windows? Will that slow 
the computer?
Yes, Hanthana can be installed on a computer with MS WIndows previously installed. This is 
called dual boot. The other operating system can be some other operating system other than 
MS WIndows. For more information on dual boot installation, please refer the installation 
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section. 

This will have no effect on the speed of  the computer. In a dual boot system, when the 
system is booting at the very beginning you are asked the operating system to be booted with. 
Only one operating system is run at a time. The only governing reason is that you have 
enough disk space in your hard disk for two operating systems. 

TOP

26). Is a virus guard required?
Not compulsory. Damages with virus attacks for Linux systems are less when compared with 
other systems. For the past 18 years, virus reported that affect the Linux kernel are too small, 
insignificant. 

TOP

27). Do I need to install Mobile Partner to connect to the internet through my dongle? 
Is there any other solution?
You do not need to install. Network Manager will identify your dongle once it is connected to 
the computer. 

TOP

28). How can I solve issues of  Hanthana Linux?
You can join our google group of  hanthana community and get answers for your issue(s) 
from the community. Use this link to join hanthana community google group 
http://groups.google.com/group/hanthana-community . Or else you may get live support by 
connecting to the IRC channel through www.hanthana.org/irc.php . 

TOP

29). It bothers me to get a large number of  emails. Is there a way to receive only the 
latest news related to Hanthana?
Yes you can. You may get only the announcements by joining to Hanthana news group. 

https://groups.google.com/group/hanthanalinux 

TOP

30). Can I contribute to Hanthana project?
1. Make you school, office friends aware 

2. Distribute Hanthana disks among your relatives, friends 
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3. Organize awareness programs and participate 

4. Prepare simple notes on how to use software on Hanthana 

5. Translate software to Sinhala language 

6. You can also add your software which is a requirement of  the community and with proper 
license to Hanthana project 

Absolutely yes. The easiest ways are to aware your friends at your school, education institute, 
office and to distribute copies among your friends and relatives. Help them to install 
Hanthana Linux on their computers. When awareness programmes are organized in your 
school of  institute, you can request the Hanthana team to be there for further awareness. 

You can educate the community by contributing to prepare simple notes in Sinhala, Tamil and 
English on how to use free and open source software. 

Join our google group for more information. 

TOP

Installation

1). What are the minimum hardware requirements to install Hanthana?
Following minimum hardware specifications will ensure your work on Hanthana easier and 
faster: 

For text mode 

recommended processor : 200 MHz Pentium Pro or faster 

minimum memory (RAM): 256 MB 

For graphical mode 

recommended processor : 400 MHz Pentium Pro or faster 

minimum memory (RAM): 640 MB 

Hanthana Linux Documentation Team 2009 – 2012 info@hanthana.org

mailto:info@hanthana.org
http://www.hanthana.org/


Hanthana Linux FAQ
www.hanthana.org

recommended memory (RAM): 1152 MB 

Hard disk minimum free space of  15GB 

A DVD ROM 

TOP

2). How to get Hanthana
It is easy! 

Visit Hanthana web site at http://www.hanthana.org , download Hanthana DVD iso and 
burn it to a DVD. If  one of  your friends already have a Hanthana DVD you may get a copy 
from that. This has no legal barrier. If  you are unable to get a copy from any of  the above 
mentioned mean, visit http://hanthana.org/media.php and contact the Hanthana Linux 
media contributor nearest to you. He/she will try his/her best to deliver you a copy. 

TOP

3). Can Hanthana be operated on 64 bit computers?
Yes. For this, use x86_64 DVD iso from Hanthana web site. 

TOP

4). How to install Hanthana?
A detailed guide on installation can be found from “Installation-Guide-H17-en.pdf ” located 
at the HanthanaDocs directory in the home directory. 

TOP

5). How to install Hanthana as dual boot?
Please refer the installation guide. Instruction there is for dual boot installation. Be careful in 
partitioning step. 

TOP

6). How can I view my NTFS (Windows NT/2000/XP/2003) partitions?
Your current partition table will be displayed in the partitioning step of  the installation 
wizard. NTFS partitions will be displayed with ntfs under ‘Type’. For more information please 
refer the partitioning step of  the installation guide. 

TOP
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Desktop Settings

1). How to enable Desktop Effects / desktop decorations?
With Hanthana 17, by default, the previous desktop effects cannot be used. But by logging to 
the system in Fail Safe Mode you may use the desktop as in Hanthana 14. There you can use 
the desktop effects the same manner. 

TOP

2). How to turn off  the computer? I cannot locate Shutdown.
Click on the user name on the top right corner of  the screen, click on Shut down... from the 
menu. 

Or else, press Alt+F2, type “halt” in the window that appear and press “Enter” key. 

TOP

Office Applications

1). How can I move a document created from LibreOffice in Hanthana to a computer 
with MS Office?
LibreOffice has the facility to save a document in MS Office format. For this go to File > 
Save As... , under File type, select the desired file type such as Microsoft Word, Microsoft 
Excel and save the document. Documents saved in this manner can be viewed and modified 
in a computer with MS Office. 

TOP

2). Can a document be converted to a PDF?
Yes. For this, go to File > Export as PDF... and use that window with your settings. More 
often the default settings are good enough for an ordinary PDF file. Next click the Export 
button. Enter the file name and location in the window that appear and click on the Save 
button. 

TOP

3). Is it only LiberOffice? OpenOffice.org, isn’t it there?
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LibreOffice is included from Hanthana 14.7 onwards and LibreOffice is developed by the 
same community that developed OpenOffice.org. 

TOP

4). How to type in Sinhala?
Hanthana Linux, by default, supports Sinhala unicode. There are two methods for you to type 
in Sinhala, one is the standard Wijesekara keyboard and the other is the phonetic method 
(type as the character sound). 

If  you have already logged in to Hanthana with Sinhala user interface, you can switch to type 
in Sinhala by pressing Ctrl + Space. If  you are logged in to the English user interface, click on 
Activities and select Other > Input Method Selector. You may get the same window with im-
chooser command in the windows appearing with Alt+F2. In that window enable “Use IBus 
(recommended)”. Click on “Input Method Preferences..” button. In the window that appear, 
go to “Input Method” tab and select “Show all input methods” from “Select at input 
method” menu. From the long list under “Sinhala;Sinhalese” select the desired input 
method(s) (such as Wijesekara, Sayura). Click on Add button after selecting the input method. 
Close both the windows. After switching to Sinhala typing mode, to switch between each 
input methods (such as Wijesekara, Sayura) use Alt+Shift key combination. 

TOP

5). Do I need to install fonts to type in Sinhala ?
Hanthana comes with the LKLUG Sinhala Unicode fonts. Therefore you can type in Sinhala 
without having to install fonts. Further more, there’s no restrictions in installing additional 
fonts. 

TOP

6). Can issues such as bold Sinhala characters and displaying of  characters such as 

"ශ" like "ශර" be fixed?
This is an issue with selecting the character layout and can be fixed with few simple steps. 
Open LibreOffice. Go to Tools > Options... from the window that appears select 
“Languages” under “Language Setting” to the left of  the window. 

Under the section “Enhanced Language support” enable “Enabled for Asian languages” and 
“Enabled for complex text layout (CTL)” and under “Default languages for document” set 

the “ Western , Asian  හා CTL” parameter to “[None]”. 

TOP
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Software Management

1). How to install applications on Hanthana ?
Applications can be installed easily by going in to Activities > System > Administration > 
Add/Remove Software and selecting the application you wish to install and clicking the 
“Apply” button. If  the applications that you need depends on other applications, the system 
will ask your permission to install those as well. You will have to enter your root account 
password for this. 

Alternatively, you can install applications by typing su -c “yum install ” in a terminal. You will 
have to key in the root account password for this. 

Note that you have to type in the application name as listed in the Fedora software repository 
and this can differ from the popular name of  the application. 

For both of  the above methods and active internet connection is a must have. 

If  you have a RPM file you can install it by executing: su -c “yum localinstall --nogpgcheck 
/complete/path/to/file.rpm” or by executing : su -c “rpm - ivh /complete/path/to/file.rpm” 

You will have to key in the root account password for this. 

Additionally, as in any other Linux system, you can compile and install an application by 
getting its source code. 

TOP

2). How to update software in Hanthana?
Updatable software will be displayed in Activities > System Tools > Add/Remove Software. 
You can update your system by pressing the “Update” button. It is necessary to provide root 
password. 

Or else, in the terminal, “su -c “pkcon update”” command (and the root password when 
asked) will also update your system. 

TOP

3). How to remove software in Hanthana?
Unselect the software in Activities > System Tools > Software Update and click on “Apply” 
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button. It is necessary to provide root password. 

Or else, in the terminal, “su -c “yum remove ”” command will also accomplish the same task. 
Root password will be required. 

TOP

4). Can exe files be installed in Hanthana? How can I do that?
exe and msi files are files that are packaged for Microsoft Windows operating system. There is 
no way to predict that each and every file of  these will properly work with a Linux system. 
But most of  those files can be installed with the aid of  a software called wine. 

Applications installed with wine are listed under Activities > Other 

Right click on the exe or msi file that you wish to install and click on "Open with Wine 
Windows Program Loader". Installation will happen the same way as it is on Microsoft 
Windows. 

exe files which do need need to be installed to run (ex: flash projector files) can also be run 
from selecting “Open with Wine Windows Program Loader” from the right click menu. 

To access software installed with wine, go to, Activities > Other. To uninstall software 
installed with wine, select Activities > Other > Wine Software Uninstaller, enter 
“Add/Remove Programs” select software to be uninstalled and click on “Remove”. 

To change the settings of  Wine, go to Activities > Other > Wine Configuration 

TOP

Software Development

1). How to use python 2.7 or 3.2 ?
For python 2.7 use "python" , for python 3.0 use "python3", for python 3.2, use "python3.2" 
from the terminal and press “Enter” 

TOP

2). When a python script is run in geany, the output is not displayed
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Go to edit -> preferences -> tool and under, and change "terminal" in to "gnome-terminal". 

TOP

Network Connection

1). How to set the IP Address and other related details ?
In order for your PC to be a part of  a computer network, your PC requires an IP address and 
some other related settings. There are two methods for this. One method is to manually enter 
these details and the other is to obtain these from the network itself  (via DHCP). 

DHCP (Dynamic Host Configuration Protocol) is used to automatically get the network 
configuration from the network itself. In order for this to happen a DHCP server needs to be 
in the network. If  your network is wireless then there is a high chance that it already has this 
in place. If  not, you’ll have to enter a matching IP address. You will have to obtain these from 
your Internet Service Provider or Network Administrator. 

For a network that has DHCP, after plugging in the network cable (if  its a wired network), Go 
to the main panel on the top of  the screen and click on the NetworkManager icon.Select the 
Wired tab for a wired network or Wireless tab for a wireless network. You can activate the 
network from these screens. 

Click on the User Name that is on the right hand side of  the main panel and from the menu 
that pops up select System Settings. Now under Hardware, select Network. You can now see 
the active network settings. For example, if  its a wired network connected on DHCP, it will 
show the Hardware Address,Speed,IP address,Subnet Mask, Default Route without having to 
enter any network settings. 

However, in order to set the network settings, select Wired category from the Wired,Wireless 
and Network Proxy categories and press the ON button. Now press the Options button and 
a new popup screen will appear with 4tabs : Wired, 802.1x Security, IPv4 Settings and IPv6 
Settings. Select IPv4 Settings tab and from the drop down menu for Method, you can select 
Automatic (DHCP) or Manual. 

If  your network has DHCP, select Automatic (DHCP), if  not, select Manual. 

In order to get IP settings automatically, select Automatic (DHCP) for Method. If  you need 
this connection to be active every time you boot the PC, enable the Connect Automatically 
option that is below the text box to enter the connection name. Finally click the Save button. 
Most likely, you’ll have to enter the root account password at this point. 
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If  there’s no DHCP service in the network, you must enter the network settings manually. 
Consult your network administrator for this and obtain the necessary details. Now under 
Method, select Manual. Click the Add button under Addresses. Enter the IP 
Address,Netmask and Gateway. Eg: IP Address: 192.168.1.10, Netmask: 255.255.255.0 and 
Gateway : 192.168.1.1 . Afterwards enter IP address of  the DNS provider for your network. 
If  you need this connection to be active every time you boot the PC, enable the Connect 
Automatically option that is below the text box to enter the connection name. Most likely, 
you’ll have to enter the root account password at this point. 

After you activate the network connection as shown above, close the Network settings 
application. You are now ready to access the network. 

TOP

2). How can I connect to the internet using my dongle?
Connect the dongle to the computer. After a little while the dongle will be identified by the 
Network Manager and click on the Network Manager icon. Select “Auto broadband” from 
the menu that appears. A window with the Manufacturer and the Model of  your dongle will 
be displayed. Select whether the Mobile BroadBand Connection that you are going to create 
use only this dongle or any other dongles are allowed to be used for the same connection as 
well and proceed. In the next window, select “Sri Lanka” as the country. A list of  all mobile 
connection service providers will be displayed, select your internet service provider and 
proceed. For the next window, if  your package is listed, select it. If  your package is not listed 
select “My plan is not listed” option, provide APN (Access Point Name) and proceed. If  your 
want to automatically connect to the internet when the dongle is connected, select “Connect 
Automatically”. 

Now your computer is ready to connect to the internet using your dongle. If  you have not 
selected “Connect Automatically”, click on “Network Manager” icon and select the 
appropriate Mobile BroadBand Connection. Now your computer is connected to the internet. 

Sometimes although the computer is connected to the internet it is impossible to view web 
pages. In such a situation please check whether the DNS Server is identified 

To safely unplug the dongle from the computer, first click on the Network Manager icon and 
disconnect the connection by clicking on “Disconnect”. If  there is any disks mounted with 
the dongle remove them, right click on them and select “Safety Remove Disk” (such as Self  
Installer Disk, Memory Chip etc.). Now your dongle can be safely removed. 

TOP
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3). I installed Hanthana Linux, but I cannot connect to the internet
The reason may be that your computer connects to the internet through a proxy server. For 
that request for the IP and port of  the proxy server from your system/network administrator. 

Now click on the user name and click on “System Settings” from the menu that appear. 
Under “ Hardware” select “Network”. Go to “Network Proxy”, select “Manual” and enter IP 
and port of  the proxy server that you obtained from your system/network administrator. 
Close the window. Now your computer is successfully connected to the internet. 

Ex:- If  you connected to the internet through a connection from the Schoolnet network, use 
10.250.20.20 as the ID and 3128 as the port of  the proxy server. 

TOP

4). How can I know the DNS of  my Internet Service Provider (ISP)?
Sometimes DNS (Domain Name Server) is not identified automatically when connected to 
the internet. If  you cannot view web pages although you are connected to the internet, the 
cause may be that your DNS is not identified. To check whether the DNS server is identified, 
right click on “Network Manager” and go to “Connection Information”. If  there are no two 
IP addresses as Primary DNS, Secondary DNS, that means that your DNS server associated 
with you internet connection is not identified by the “Network Manager”. For a successful 
internet connection at least the Primary DNS is required. 

This issue can be resolved by manually configuring DNS server settings. Click on the user 
name at the top right of  the screen, select “System Settings” from the menu that appear. 
Under “Hardware” select “Network” click on “Wired” from the window that appear and click 
on “Options...” to change settings of  the network. Under “IPv4 Settings” tab enter DNS 
server settings. When entering many DNS, separate them with a , (comma). 

1. If  it is Wireless or wired connection, choose Method -> Automatic (DHCP) addresses only 

2. If  it is a Mobile BroadBand using a dongle, choose Method -> Automatic (PPP) addresses 
only 

3. If  it is a DSL connection, choose Method -> Automatic (PPPoE) addresses only 

Now enter the Primary DNS IP of  other DNS server and enter the secondary DNS server IP 
separated by a comma. 

TOP
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User Management

1). How can I change my password?
Click on the user name on the top panel and select “My Account”. “User Accounts” window 
that appear will show your user name, language and password. Double click on the password, 
enter the current and new passwords in the window that appear. The password hint you 
provide will be displayed in the login screen, therefore please note that you password hint is 
visible to all the users of  the system. Do not include the password in the password hint. After 
changing the settings click on the “Change” button. 

Or else, in the terminal, issue the command “passwd ” as root. Provide the current password 
and press enter. Provide the new password and press enter. Provide the new password again 
and press enter. 

TOP

2). How to create a new user account in Hanthana?
Go to Activities > Other > Users and Groups. Root password will be required. In the 
window that appear click on ‘Add User’ button. Enter user name, full name of  the user, 
password and the password again on the window that appear and click on “OK” button. 

TOP

3). How to delete a user account in Hanthana?
Go to Activities > Other > Users and Groups. You will be requested with the root password. 
Select the user name of  the account you want to delete and press ‘Delete’ button. A message 
will be displayed asking whether you want to delete the home directory, directory containing 
documents and temporary files of  the user. If  you want to delete these press ‘Yes’ button. If  
you want to keep those files untick the message and press ‘Yes’ button. 

Or else, in the terminal, issue the command ‘userdel ' and the user will be deleted. 'userdel -r ' 
command will delete the user along with the above mentioned directories such as the home 
directory and temporary files that belong to the user. 

TOP

4). How can I modify a user account in Hanthana?
Go to Activities > Other > Users and Groups. You will be requested with the root password. 
Select the user name of  the user account that you want to modify and press ‘Properties’ 
button. There you can change settings such as user name, full name, password, whether the 
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password should expire, if  so when and in what situations etc. After changing the settings 
press ‘OK’ button. 

TOP

Security Settings

1). What is SELinux?
SELinux (Security-Enhanced Linux) is a security mechanism developed for Linux based 
operating systems. Permission for processes running in the system are limited and thus will 
reduce the risk associated with security. 

TOP

2). What effect will be there for my day to day activities due to SELinux?
Enabling of  SELinux will have no effect on normal usage. Sometimes issues will arise. For 
example in situations such as connecting an additional hard disk, sharing /home with two 
Linux based operating system using SELinux, installing and using some software. 

TOP

3). How to enable/disable SELinux?
Go to Activities > Other > SELinux Management. To disable SELinux, under ‘Status’, 
‘System Default Enforcing Mode’, change ‘Enforcing’ or ‘Permissive’ into ‘Disabled’. 

TOP

Mobile Phone Settings

1). Can SMS and contacts in my mobile phone/dongle be viewed in Hanthana?
Wammu software will help you for this. Connect your mobile phone or dongle to the 
computer, go to Activities > Applications > Accessories > Wammu and load Wammu. Most 
of  the time if  the settings for your mobile phone or dongle are not there in Wammu, it will 
ask you whether you want to set settings or else go to Wammu -> Phone wizard. Proceed 
with ‘Next’ in the window that appear. You will be provided with three options and select the 
easiest ‘Automatically search for a phone’ and proceed. Next select how you have connected 
you mobile phone or dongle to the computer (ex: if  it is mobile phone whether it is 
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connected via bluetooth or via a USB cable) and proceed. From the web page in the link you 
can check whether Wammu supports your mobile phone or dongle. In the next window 
please be patient until Wammu identifies your mobile phone or dongle. Next you will have a 
window with “Configuration done” and that means Wammu is ready to connect to your 
mobile phone or dongle. Click ‘Finish’ and save the settings. 

By default, Wammu will not automatically connect to your mobile phone or dongle when it is 
loaded and if  you want to do so select the option, ‘Wammu -> Settings -> Automatically 
connect to phone at startup’. Or else you have to connect with Phone -> Connect. Next a 
message will appear with ‘One moment please. connecting to phone....’ and once it is 
disappeared that means Wammu is connected with your mobile phone or dongle. Retrieve -> 
Info will get you the manufacturer, model, information about the SIM, IMEI number etc. of  
your mobile phone or dongle. Sometimes when you are connected to the internet using a 
dongle Wammu may fail to connect to the dongle, in such a situation disconnect the internet 
connection by selecting ‘Disconnect’ in Network Manager and retry to connect with Wammu. 

Wammu connecting along with a mobile phone or dongle will not read contacts, SMS etc. 
Retrieve -> Contacts (All) will import all the contacts in the phone memory and in the SIM 
into Wammu. If  you want contacts only in the phone memory, select Retrieve -> Contacts 
(Phone) and if  you want contacts only in the SIM, select Retrieve -> Contacts (SIM). You can 
read, edit and delete contacts and to add new contacts, follow Create -> Contact. 

To read SMS you can import them by Retrieve -> Messages. SMSs will be categorized as 
Read, Sent, Unread, Unsent under ‘Messages’ in the left pane of  the window. You can read 
and delete SMSs. To sent a SMS, go to Create -> Message. You can provide the number of  
the recipient or choose one from contacts by clicking on ‘Add’. Click ‘OK’ to send the SMS. 

Wammu cannot be used to read SMSs in real time and for that you can use Gnome Phone 
Manager. You can load Gnome Phone Manager by Activities > Applications > System Tools 
> Phone Manager. Mobile phone icon next to the Network Manager icon is the Gnome 
Phone Manager icon. If  it is displayed in a red background, that means it is not connected 
with your mobile phone or dongle. In such a situation you have to set settings in Gnome 
Phone Manager. For that right click on the Gnome Phone Manager icon and select 
‘Preferences’ and under ‘Connection’ tab, select your mobile phone or dongle. If  your mobile 
phone is connected via bluetooth, select the bluetooth option and select by ‘Click to Select 
device’. Or else the easiest option is to select ‘Other port’, open Wammu, go to Wammu -> 
Settings -> Connection -> Device, and copy and paste the value there. To automatically 
reconnect when the connection drops with the mobile phone or dongle, it is important to 
select the option ‘Automatically retry connections’. How a SMS is displayed when it is 
received can be set in the ‘Interface’ tab. ‘Pop-up window for new messages’ will open every 
new SMS in a new window and ‘Play sound when messages arrive’ will play a sound when a 
SMS is received. 
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If  new SMS is received in Gnome Phone Manager it will be notified with an icon of  an 
envelop with a white background. To read the SMS, click on Gnome Phone Manager icon and 
you can reply by clicking on the ‘Reply’ button on the same window. To send a SMS, right 
click the Gnome Phone Manager icon, click on ‘Send Message’, enter the message and 
recipient and click ‘Send’. 

If  you want to start Gnome Phone Manager when you log into the system, open System -> 
Preferences -> Startup Application, click ‘Add’, in the window that appear under ‘Command’ 
enter "gnome-phone-manager" and click ‘Add’. 

TOP

Other

1). How can I view the space on my hard disk?
Go to Activities > System Tools > System Monitor and under ‘File Systems’ tab, you will be 
provided with the information such as the capacity, free space, file type of  your current 
partitions. In addition you can use ‘df  -h’ command in the terminal. 

Gnome and KDE have provided two System Monitor software and click on the first icon 
from the two. 

TOP

2). How can I view internet speed, CPU and Memory?
Go to Activities > System Tools > System Monitor. Your required information will be listed 
under ‘Resources’ tab. 

Gnome and KDE have provided two System Monitor software and click on the first icon 
from the two. 

TOP

3). How can I find a file in the disk?
Click on Activities. A search box will appear in the top right of  the screen and enter the name 
of  the file, directory or application that you want to search. 

Open File Browser (Nautilus) in the right hand side, under ‘Go’ in the main menu, click on 
‘Search for Files..’. 
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You can use the ‘locate’ command in the terminal to find a file with the file name and ‘find’ to 
find files based on many parameters such as file size, file owner. The output of  ‘locate’ 
command will be more accurate of  you have issued ‘updatedb’ command before ‘locate’. If  
not ‘locate’ will output files that you have deleted a while ago. 

TOP

4). How can I find more information on a command in a Linux based system?
'man ' command in the terminal will get you a complete description of  the command 
including it’s usage and other related commands. 

Ex:: ‘ls’ command will list the files and directories in a specified location. 

‘man ls’ will get you a lot of  information on ‘ls’ command. 

TOP

5). How can I log in to the Sinhala user interface of  Hanthana?
In Hanthana login screen click on the user name and from the language selection menu at the 
bottom left of  the screen (currently displayed as “English (United States)”) select “Other...”. 
From the list of  languages, select “Sinhala (Sri Lanka)” and click “OK” button. Now enter 
your password and log into Hanthana workspace. 

TOP

6). What is ‘terminal’?
One of  the important facts that we should know in using a Linux based system is how to use 
the Linux terminal. Linux terminal is a mode of  issuing command to the computer in a Linux 
based operating system. Although Fedora is a fully graphical system, if  you wish you can use 
the terminal to issue commands to the computer. All the commands that you issue in the 
graphical system can be issued using the terminal as well. You may feel that this is a little bit 
difficult to use at the very beginning, but once your are get used to the terminal you will 
hardly use the graphical user interface. 

Go to Activities > System Tools > Terminal to open the terminal in Fedora. 

TOP

7). What is ‘root’?
‘root’ is the user with all the privileges in a Linux based operating system. In simple ‘root’ 
login will allow you to do anything you wish in a Linux based operating system. This is also 
called ‘super user’ 
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This documentation was composed by the community for the betterment of  the 
community. We invite you to point out any mistakes in the here and to join with us to 
improve this documentation. You may contact us through info@hanthana.org
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