Index: [thread] [date] [subject] [author]
  From: Marcus Sundberg <e94_msu@elixir.e.kth.se>
  To  : ggi-develop@eskimo.com
  Date: Thu, 13 Aug 1998 02:00:08 +0200

ggi_key_event confusion

Currently ggi_key_event has these three entries:
        uint32  sym;            /* meaning of key (action)      */
        uint32  code;           /* keyboard's code for key      */
        uint32  label;          /* label on key                 */

The only obvious entry is "code", and that is not properly implemented
(or implemented at all) on most targets.                       

What we need is one entry describing what physical key was pressed
and one entry describing the meaning of that key, with regard taken
to modifiers and such. And we need _every_ supported value for both
these entries to have a corresponding GGI_* define.

I suggest that we have a "code" entry with corresponding GGI_KCODE_*
defines and a "sym" entry with corresponding GGI_KSYM_* entries.

Comments?

//Marcus

Index: [thread] [date] [subject] [author]